shaky video in openGL (win10/amd)

Blade of Darkness general discussion and game help forum. Discuss anything related to Severance / BoD (except modding, use the forum below) Note: Possible spoilers!

Moderators: Ade, prospero

User avatar
cieply
Dragon
Posts: 312
Joined: Wed Jun 26, 2013 3:43 pm

shaky video in openGL (win10/amd)

Postby cieply » Mon Mar 05, 2018 9:39 pm

I have "new" hardware (AMD A8-6410 win win10) and it poses some problem with game: picture is kinda shaky/jerky in OpenGL, certainly not smooth as it was somewhat slow computer which is not the case. It's even worse while recording video which is irritating. In D3D is somewhat better but with AMD this renderer suffers the black fonts ans "invisible menu" which is unplayable really - so it's not an option.
Did anyone experienced such behaviour and know any remedy to that?
l'aria fresca,
vino puro, ...

User avatar
Blackbeard
Dragon
Posts: 124
Joined: Wed Jun 24, 2009 7:54 am
Location: Sweden

Re: shaky video in openGL (win10/amd)

Postby Blackbeard » Sat May 05, 2018 3:04 pm

Well, i just installed it on my computer and started it up.
My specs are:
AMD FX-8350 CPU
Nvidia 1050Ti
Windows 10

I only play with OpenGL, cause i know it works, the only problem you have with that is the thick fog, but there is a map pack that fixes that, i dont really see a reason not to use it, but theres always "3Dfx Glide" if you wanna use that instead.

And about the shaky video, i didnt have any of that.


(Looking more into it) It seems that there is a flickering from lightsources, reminds me of not having vertical sync on in some games.

User avatar
cieply
Dragon
Posts: 312
Joined: Wed Jun 26, 2013 3:43 pm

Re: shaky video in openGL (win10/amd)

Postby cieply » Sat May 19, 2018 10:49 pm

I tried brand new drivers, had some issues with them and the problem is pretty much the same, maybe slightly better but it's still unsatisfactory.
There is no good reason to play in D3D cause fonts are black, therefore not visible and 3dfx wrappers aren't answer either as they allow to play in 640x480, and some in 800x600 maximum.
I'm pretty sure it's the drivers' issue but who will bother with 17 years old game.
I guess it has to be this way.
l'aria fresca,
vino puro, ...

User avatar
Blackbeard
Dragon
Posts: 124
Joined: Wed Jun 24, 2009 7:54 am
Location: Sweden

Re: shaky video in openGL (win10/amd)

Postby Blackbeard » Sun May 20, 2018 2:09 am

Have you tried forcing 1 cpu core for Blade? (i dont remember how to do it, but i recall having to do it for fallout 3 when i last played that some years ago)

Also forcing 'vertical sync' might help as well, for me the flickering from lightsources got reduced when i did that.

User avatar
cieply
Dragon
Posts: 312
Joined: Wed Jun 26, 2013 3:43 pm

Re: shaky video in openGL (win10/amd)

Postby cieply » Wed May 23, 2018 5:28 am

I tried with no luck. I found on GOG that limiting affinity to one cpu is useful when your game is working too fast - kind of error like with old dos games working too fast on newer computers. You can do it either by starting game with program that does that for you or limit it in any process manager like process explorer or task manager.
l'aria fresca,
vino puro, ...

User avatar
Blackbeard
Dragon
Posts: 124
Joined: Wed Jun 24, 2009 7:54 am
Location: Sweden

Re: shaky video in openGL (win10/amd)

Postby Blackbeard » Wed May 23, 2018 6:10 am

Hm, well thats all I got.


Return to “Severance BoD: Help / Game Discussion”

Who is online

Users browsing this forum: No registered users and 2 guests

cron