Page 1 of 1

Endlessly Looping Cutscene at the Poison Crystal

Posted: Fri Mar 02, 2018 10:09 pm
by FoxMagic
Hello! I am new to the forum and searched for an answer to this issue, but have not found a solution. Also, thank you to everyone who make this website possible. Thanks to Arokh's Lair I found the information and patches necessary to install and run my old version of Drakan on my new computer.

I am stuck on an endlessly looping cutscene at the Wartok Mines. After opening the main gates from the inside, I mount Arokh and battle the green crow dragon. After killing the dragon, the poison crystal rises from the ground, and I fly to the floating crystal to get the poison breath for Arokh. The game then enters a cut scene, which loops endlessly. I try to exit the cutscene by hitting enter, any other combination of keys, print screen, etc. No luck. I've even tried to continue the game without getting the power by using cheat codes to open the gate and cross the river inside, but the game crashes, probably because I didn't "finish" the level by getting poison breath.

Any ideas or suggestions for getting past this glitch would be appreciated.

I am running OoTF on a Surface Pro, with Windows 10. I am running on the 445 and AiO patches. The 10th anniversary Mod didn't work on my system.

Thank you!

Re: Endlessly Looping Cutscene at the Poison Crystal

Posted: Sat Mar 03, 2018 2:09 pm
by Arokhs Twin
Hi there, welcome to the forum. That bug isn't something I've heard of before. What patch are you using? It may be something caused by one of the player patches which can be fixed or if the worst happens someone can send you a save game after that point but it would have to be a save from the same version as yours.

Re: Endlessly Looping Cutscene at the Poison Crystal

Posted: Sun Mar 04, 2018 2:47 pm
by shoprat
You could try to fight the dragon without Arokh and then walk him out. I don't know if it'll work but it should be fun anyway. Use the cheats and get some invulnerable potions and a few energy bows or a speed bow and some magic arrows. Both use homing arrows so they should hit the moving dragon boss. Keep Arokh in the cave, take your potion, and go out and kick some butt. When he's dead hop on Arokh and walk him out of the cave and away from the power-up. You may be able to come back to the area later and get the crystal it but it doesn't look good. Not sure if there's a cheat to get poison breath but you could try gimme poison crystal and see if it works. Hopefully someone can give you the correct cheat if it's not the right command.

Re: Endlessly Looping Cutscene at the Poison Crystal

Posted: Sun Mar 04, 2018 5:20 pm
by FoxMagic
Hello! Thank you for very much! I am happy to join! And thank you for looking into my issue.

I am pretty sure I am using the 445 patch and the AiO patch. When I installed OoTF, I followed the installation instructions from Ucyborg found here: (17 September 2014, 9:38am). I extracted the from my original Drakan CD (english language version), then extracted the 445 patch cab, then extracted the AiO 2.113 patch drakan.exe and dragon.rfl files into the install folder. I downloaded the patches from the links is Ucyborg's post.

I tried shoprat's "gimme poison crystal" cheat idea, and tried killing the crow dragon from the ground, then trying for the powerup/trying later but no luck. I even left the cutscene playing to see if it resolve itself, but gave up after half an hour.

I'm happy to try another patch if that might work, or another sequence. I downloaded the Drakan Gold pack for backup purposes from your forum, so could extract those if needed. I might also try the entire level from the beginning again, just for fun, but am not sure that will do anything.

Again, thank you for any help you can offer!

Re: Endlessly Looping Cutscene at the Poison Crystal

Posted: Sun Mar 04, 2018 10:22 pm
by Arokhs Twin
There's a new update to the AiO patch which you could try; note that this latest patch changes the location of your save games so you may have to move them. The problem may be caused by a save game created with a different patch version to the one you are using now. Have you patched the game during your playthrough? Make a backup of your save files before trying the new patch I suggested above.

Seem as you are near the end of the Wartock Canyons level it would be a lot of work to play through this level again but if the new patch fails to fix it I would try loading an earlier save game and try again especially if you have patched again during your playthrough.

I've updated the main site page with the fixes and download link to the new version.

Re: Endlessly Looping Cutscene at the Poison Crystal

Posted: Sun Mar 04, 2018 10:52 pm
by UCyborg
AiO Patch is currently at 2.117. Since you've installed the game manually by extracting files from installer, I should mention that the only plausible reason for game's installer not working (besides possible disc damage due to age and other factors) is having a badly written program running in the background. The old InstallShield installer is used to install the game. It has the quirk that it broadcasts specific message to all windows on the system and doesn't proceed until all programs have responded to the message. The message doesn't have any meaning to most programs, but they must all respond to it, otherwise the installer will freeze indefinitely. If that's the case, it means you have something bad running in the background and should at least terminate it to let installer run.

Windows 8 and newer's Task Manager have a "Analyze wait chain" option you get by right-clicking installer's setup.exe on Details tab. It tells which process is blocking the installer. If that's actually the case, you've got a problem. After all, most crapware is written for Windows. For older Windows versions, Process Hacker can be used to find out what blocks installer. The procedure is a little different, after you double-click setup.exe, you need to go to Threads tab, then right-click on threads in the list and select Analyze->Wait to pinpoint problematic process. Just for informational purposes.

Regarding the problem at hand, you can definitely try and see if the issue re-occurs if you launch the game in developer mode and start playing Wartok Canyons level from scratch using New Game option. You'll need cheats to arm Rynn and Arokh. Also, Surreal's games in general are known to have issues if they run too fast. I've put a frame-limiter in the latest AiO Patch to avoid some of the oddities.

Also, which Gold Pack have you downloaded? This version is fully patched. Definitely try it and see if you encounter any issues with it. The added levels are good addition, though for single-player stuff, you've got to search folder for readme files to see which is the starting level for certain campaigns that span multiple levels and to learn a backstory, if any. Also because level list after clicking New Game is a mess when you got every level in place. :D It'd be nice if it was possible to distinguish single-player levels from multi-player levels.

My guess for the looping cutscene problem would be that maybe something goes wrong when reading game data from disk, making the engine not realize the cutscene has finished and therefore breaking out of the playback loop. Same could be said for crash on level transition. It can also happen that the game corrupts save game, which could be verified that this isn't the case by starting Wartok Canyons again from New Game while in developer mode. Though the only savegame issue I remember being able to reproduce consistently in the past myself was on Islands level. In the Goblin base, saving the game while the trap with poison gas was hissing then reloading it would result in extremely low frame-rate, probably due to some garbage data ending up in the saved file. It's good to have multiple saves from various points in the game for cases like this.

I've mentioned somewhere else that the savegames from version 445 and any AiO Patch version are compatible since there haven't been any changes to the savegame format, so it's safe to assume that savegame compatibility is not an issue here. Official patch version 445 ReadMe documents the crash that would occur in such case when attempting to load incompatible save.

Re: Endlessly Looping Cutscene at the Poison Crystal

Posted: Sun Mar 11, 2018 2:41 pm
by FoxMagic
Thank you for all you suggestions and help. :D

I installed the AiO 2.117 patch, but the cut scene still looped endlessly. I then uninstalled Drakan, and installed the Enhanced Gold edition (I had some problems extracting the 7p file, but finally managed to do it with WinRAR, which I should have used in the first place :oops: ) Unfortunately the cutscene looped with the enhanced version, too. I tried uninstalling the enhanced gold and installed the earlier version (Gold 2015), but the save game wasn't compatible. Finally, I reinstalled Drakan from my original install disk. Ucyborg's explanation of the "Analyze Wait Chain" was very helpful, as that was the problem I was having installing the game originally (and I think it is why I am having trouble with some other older games I've tried to install). I then patched with 445 and AiO 2.117, and played through the entire Wartok Canyons again, from when Rynn exits the cave on the other side of the Ruined Village. No luck. The cutscene still endlessly loops.

I am planning to start a new game and play through to the cut scene again, to see if the problem occurred even earlier in the game. I save a lot so I can go back and retrace my steps if I need to. I'll also try playing Wartok Canyons from the New Game menu, though when I try to play specific levels from this menu they often crash.

Again, any suggestion would be most appreciated, and thank you again for all your help. Troubleshooting this problem is almost as much fun as the game itself :D

Re: Endlessly Looping Cutscene at the Poison Crystal

Posted: Sun Mar 11, 2018 4:47 pm
by FoxMagic
I played through Wartok Canyons through from the new game screen, and still got the endless loop at the rune of poison. I also tried closing all background programs and services in case that was causing the problem. No luck. If I fly into the rune of poison at just the right angle, the game crashes. I tried analyzing the wait chain during the sequence, and there doesn't seem to be anything interfering with the normal operation of Drakan. At this point I am stumped. Any help or suggestions would be appreciated. Thanks!

Re: Endlessly Looping Cutscene at the Poison Crystal

Posted: Mon Mar 12, 2018 4:47 am
by Mechanist
I believe the correct command is "gimme poison", without the " " of course.
Not 'poison crystal'; that would refer to a nonexistent weapon (offensive item) for Rynn.

This should work, and AFAIK there are no in-game consequences caused by skipping the actual pickup and cutscene; the fastest glitched speedrun skips pretty much ALL of them and finishes the game without any problems.

If any of the subsequent cutscenes give you the same problem, try using "all weapons", this should list all the available names, then you can "gimme" whatever the given crystal represents.

Unfortunately I'm only positive about "gimme fire" and "gimme poison"; can't check anything else right now: my Drakan install is messed up from trying (and failing) to get the 10th mod to work properly, and subsequently removing it - now it crashes just before entering main menu. That doesn't bother me now though, because in about a month my new computer will be up and running, and this one gets mothballed.

EDIT: If - for some unfathomable reason - the above does not work (but it should, if you've got cheats enabled), try turning all the graphics options to minimum/off, and then try entering the cutscene again.
Especially bump mapping could be problematic - that one in particular is linked to some known stability issues.

If you get a game crash upon exiting the level despite using "gimme poison", try this: DON'T fight the green dragon. At all. For all I know, this is likely the source of your crashing problem.
Try playing the level normally, more or less up to that point, and then noclip out-of-bounds around to the level exit, without activating the green dragon fight.

Finally, take care what you noclip around. The levels are full of invisible trigger zones, and skipping some of them (or even worse, hitting them in a wrong order) can cause problems.
The abovementioned glitched speedrun route skips the 1st Arokh model load trigger (there are only 2 in the game AFAIK, many levels apart!), and so ends up playing roughly half the game without a visible Arokh model.

OK, I managed to get my broken install of Drakan kinda working, at least for long enough to test this:

Hold down SHIFT while starting "Riot Engine Options" - an extra "Developer" tab will appear therein.
Select "Enable Developer Mode" and start the game. Load your save as normal.
While in the game, press \ to show the command line.
The following commands will then work to give Arokh his breath weapons:
gimme fire
gimme poison
gimme ice
gimme lightning
gimme magma