Page 1 of 1

Sequence breaks, glitches, secrets, ghosts of content cut, and other observations...

Posted: Sun Apr 22, 2018 8:37 pm
by Mechanist
As part of the preparations for my LP, I'm very thoroughly investigating OOTF's levels - including the areas not normally intended to be seen :D

Here's a list of my findings, which will be updated concurrently with my progress through the levels.
Some of these things are probably already known, but I guess that it's nice to have it all grouped in one place nonetheless.

Of course I'll be showing this off, in video form, in the bonus content for my LP :)

However, in this list, I'm not including most of the craziness that can be caused by clipping out-of-bounds with Arokh; nor by item boosting, sword block clipping or sword block flying - simply because that's far beyond anything the developers could have possibly expected the player to do. The same logic applies to using console commands.
I'll only mention the most noteworthy of these instances.
As for the sequence breaks, I'm only going to mention those which can be performed without relying on any cheats or glitches - because with heavy glitch abuse, OOTF can be "completed" in under 15 minutes; at least for some definition of completion (as in, reaching the ending).

BTW: if anyone happens to notice any errors in this list, please point them out.
I have gone to great lengths to try and ensure that it's largely free of both typographical, as well as factual errors - but given the size of it, it's inevitable that some mistakes might have slipped through.

Latest update: 29/04/18 (Added some new information, and reformatted the list somewhat for better readability)

General findings (not level-specific):
  • Observation: many of the waterfalls in the world of Drakan - even some of the smallest ones - have the bizarre property of instantly shredding Rynn into mincemeat on contact; including when approaching from the downstream side! The areas of calm water to the sides, on the upstream side of the waterfall, appear to be especially deadly; they make Rynn explode upon the slightest touch :shock:.
  • Observation: Rynn can actually swim against the strong river current fairly well, by clinging to the riverbed. Perhaps she's using it to "climb" its surface, like how rock climbing normally works on land?
  • Observation: enemies in OOTF can most certainly hit and hurt each other, even if they are supposed to be on the same team. Many times I've witnessed one wartok accidentally hit another instead of Rynn, whereupon they promptly forgot about her and started bashing each other to death!
  • Unrelated observation: you're now probably reading these "Observation: (...)" lines in HK-47's voice, meatbag :wink:
  • Model reuse leading to a possible inconsistency: the Mithril Sword is obviously a direct copy of the design for Atimar's Blade (which, I presume, might actually date all the way back to the times of the Order?).
    It's apparently composed of a superior material, dealing twice the damage; yet it can break like any other weapon.
    One plausible explanation is that the glowing hilt of Atimar's Blade signifies that a durability-boosting enchantment had been applied at some point; which is why it's effectively unbreakable, despite being made out of an inferior material.
  • Geographical protection fault / continuity error: the direction of Rynn's progress through the world is not consistent with how the levels are laid out. She leaves her village to the west, but then starts at the western end of Wartok Canyons and goes towards the east; a clear contradiction.
    And that's not even considering what we learn of Drakan's geography in TAG.

Glitches, bugs, and other oddities (not level-specific):
  • Inconsistent movement physics allowing various sequence breaks: Rynn's diagonal jump allows her to cover significantly more distance than a straight jump would; likely due to an incorrect implementation of jumping physics.
    This allows her to reach some areas of the levels earlier than intended by the developers, sometimes making major skips possible.
  • Game-breaking bug allowing major sequence breaks: the "sword block flying glitch". Turns out that it was very much alive and well for a very, very long time; but now it's been fixed since AiO patch version 123.
    How to perform: have Rynn hold a weapon that she can block with, then jump forward so that Rynn lands on the very edge of some geometry; such that she would fall off when taking another step forward - it won't work otherwise!
    As she's recovering from landing the jump (not before landing!), press jump+forward+(left or right)+block. She should start falling off the edge, but immediately enter the block pose and stop falling any further. Keep holding block to keep flying; the other keys can be released though.
    If it didn't work, try landing slightly closer to the edge.
    Note that Rynn can't gain altitude in this state; any contact with the level geometry will cancel the glitch.
  • Game-breaking bug (physics): trying to jump over some steep slopes can result in Rynn being flung sideways with extreme velocity if she "catches" on an intervening slope in mid-jump, causing her to be instantly splattered to gibs upon contact with any solid obstacle - including the terrain, of course.
    I know of at least one particular spot in Ruined Village where that effect can be semi-consistently reproduced.
  • Game-breaking bug (physics): the "item boosting" glitch - drop an item on the ground, stand facing it but from about 1 meter away, jump straight up, and spam the "Use item" key during the jump.
    If all the moons of Drakan are correctly aligned, Rynn will now be propelled backwards with a great velocity - sadly, this usually ends in her prompt demise on impact with the terrain; sometimes she survives the process, albeit with major wounds.
  • Game-breaking bug (array index out of bounds and/or dangling pointer?): placing a 2-slots-wide inventory item in the rightmost column (doing that shouldn't be allowed in the first place!) causes bizarre results, up to and including duplication of the item in question.
    However, the duplicated item isn't quite a perfect copy of the original: saving and reloading can cause the copies to become corrupted and impossible to interact with; also, while experimenting with the duplication, I managed to cause a very nasty crash (not a BSOD) which effectively brought down the entire OS.
    Note: this has been partially fixed since AiO patch version 122.
  • Poorly coded AI?: the "Arokh's indifference" bug.
    Arokh's AI can sometimes enter a bugged state, in which he'll follow Rynn around, but won't help her in any way. He'll just fly around and stare idly at the enemies, even if they're busy pounding her to a pulp. Doesn't matter if they are within range, he still won't engage them.
    It seems to be quite random, but I've had some measure of success invoking that state by deliberately hitting Arokh with a weapon, so that he takes off without Rynn.
    In any case, when he's called, he quickly snaps out of it, and starts blasting the enemies. Immediately, if they happen to already be within range.
    Note that this usually doesn't happen when an enemy hits him while on the ground, since in such cases there already exists a suitable target for his wrath?
  • Failure to properly initialize some variable(s)?: the "Rynn's stiff back" bug.
    At the beginning of Wartok Canyons, Rynn doesn't perform her usual animation of attempting to stay vertical when Arokh flies a banked turn. This way, it actually ends up looking more natural when considering the forces involved, for the same reason as when riding a motorbike.
    Such a state persists until Rynn dismounts and re-mounts Arokh for the first time. Saving and reloading has no effect.
    Possibly it's a side effect of the dragon controller having been disabled for the near-entirety of Ruined Village (except for the last few frames)?
  • Strange left/right movement asymmetry:
    For some odd reason, the OOTF engine handles turning/strafing to the left slightly differently than towards the right; although this appears to have no significant effect on the actual movement, beyond the different visual appearance.
    With Rynn, her ponytail shows considerably different behavior depending on whether she's strafing left or right.
    On the ground, it's also evident when looking at Arokh's neck bending slightly as he turns/strafes - again, it's strongly direction-dependent.

Unexpected behavior:
  • General: forcing Arokh to enter a body of water causes odd things to happen.
  • Ruined Village (Arokh's lair): interestingly, approaching the pedestal in Arokh's lair unconditionally activates the bonding cutscene - even if Rynn has somehow sequence broken all the way past Heron's soul crystal, and thus doesn't even have it with her!
    She simply pulls it out of thin air with the power of the plot :D. Again, everything proceeds normally after that.
  • Ruined Village (Arokh's lair): noclipping or dropping onto the elevated platform where Arokh stands in his stone form, reveals that in this state he is actually totally insubstantial! Which is rather odd, since I expected it to be just a simple texture swap of Arokh's usual model.
    This is likely related to the fact that the real Arokh is sitting on the floor below, but is invisible and has no collision before the right point in time.
  • Ruined Village (Arokh's lair): "Things to do in Arokh's lair when Rynn is dead" :roll:.
    It turns out that even when Rynn is dead, it's nonetheless still possible to trigger the bonding cutscene!
    This can be accomplished by falling sufficiently near the central pedestal (not directly on top of it) from a suitable height - but note that if the drop is too great, Rynn will splatter into gibs instead, and the trigger won't activate! She needs to still be in one piece for that to work.
    One (fun) way to do that is to slide down the rim of the exit opening (after reaching it from above), and perform 2 skullsplitters on the way down to reduce the falling damage, so that Rynn will merely collapse and die, instead of exploding into a spray of meat.
    Another, much simpler method is to just jump from the spiral path. But not from the high ledge, as the fall is too long from there; instead, use the triangular protrusion of rock a short way down the path.
    Whatever the method though, the results are rather... anticlimactic: the cutscene plays as normal for the most part, although it's likely that whatever weapon Rynn was carrying is now weirdly embedded into the central pedestal; of course when Arokh reaches the level transition to Wartok Canyons, the game transfers control back to the player, as usual. Normally this would immediately activate the level transition, with the player in control of Arokh at the entrance to Wartok Canyons.
    However, in this case, it ends very poorly instead, since the game has only just now realized that we've been Bad - so rather than go to the next level, Arokh just immediately drops dead on the spot, but with Rynn now in an apparently undead state, stuck in the riding pose in midair.

Unused/cut content, level editor & behind-the-scenes stuff:
  • Observation: the icon for the Level Editor (3 gears meshed together) depicts a system where none of the gears can turn at all! Make of that what you will... :roll:
  • Observation: items (eg. health elixirs) contained inside breakable containers are actually predefined, not randomly generated.
    This also applies to potions dropped by enemies - who, in the end, are effectively just another kind of breakable container; merely somewhat more durable and vicious than the other container types.
  • Name changes in the middle of game development: a bunch of characters' names used internally in the editor are very different from how they're actually named in the game proper.
    For example: Arokh is simply called "Dragon", Atimar is "Julian", Navaros is just "Dr. Evil", wartoks are inconsistently referred to as either "orcs" or "hueges" (whatever that is), and crow dragons are interchangeably called either "crow dragons" or "blade dragons".
    There are lots of spelling errors in the level data, in general (ie. Arock, Aroch, "SROMP" instead of "STOMP", etc.), which seems to suggest a very lax development attitude towards quality and/or consistency.
  • Unimplemented/unused features: the available parameters in the level editor seem to indicate that NPC dragons (including crow dragons) are also capable of carrying NPC riders - but AFAIK, this feature isn't actually used anywhere in the stock game. I'm not sure if it functions properly - or even at all, to begin with; I haven't tested that in any way.
  • Behind the scenes (Ruined Village book sequence): the way the book sequence is executed is quite interesting.
    It's actually a separate level, in which a slideshow had been assembled using the engine's existing assets; an elegant way of creating an unusual setpiece without having to code for it specifically.
    For some reason, it reminds me of the "wearing a train car as a helmet" technical trick, which was utilized in Fallout 3 :).
  • Unused animation: Arokh has an unused animation for running (not flying) into a wall. Well, not entirely unused - it's utilized once, in the bonding cutscene, right after he's awakened.
    The animation slot for Arokh running into a wall exists, but appears to be broken - assigning that animation to its slot doesn't result in the expected behavior; as if there's something else preventing that from working.
  • Evidence of cut content (Ruined Village): the 3 opening cutscenes are internally labelled "1.1", "1.2a" and "1.3". The bonding cutscene is "1.6b".
    Note that the backstory book cutscene doesn't count towards this - the "book sequence" slideshow is actually a single sequence which takes place in a completely separate level; and the cutscene of the temple floor opening and Rynn descending the stairs doesn't follow this labelling scheme, either.
    So where did cutscenes 1.4 and 1.5 (and possibly 1.6a) go? :?:
    Further evidence pointing towards missing content is provided by the game itself, at the very beginning of Wartok Canyons: upon exiting the starting cave, Rynn tells Arokh of a wartok who mentioned the Grimstone Mines - but no such thing actually happened at any point in the Ruined Village!
    Also, the bonding cutscene itself doesn't quite stand up to close scrutiny: Arokh first objects vehemently, then rapidly backs off for no apparent reason; he also omits a whole lot of significant details - most of which Rynn would have probably already known from listening to Atimar's stories, but which the (first-time) player doesn't know; and the final part also feels off - he's now stuck with Rynn for the next century (or thereabouts), and doesn't even say a single word?
    Not even to ask which direction are they supposed to go?
    Looking in the level editor, in the voiced lines for the bonding cutscene, there's an unused line for Rynn: "Heh, easy for YOU to say!" (#14).
    Going by the numbering used, it would've been Rynn's reply to Arokh telling her the words to speak - although it doesn't seem to fit very well; maybe that's why it was cut?
    Unfortunately, Arokh's reply to that isn't present at all :( But evidently there was supposed to be one, since the next number in the sequence (#15_1) is not used. Furthermore, in the STOMP sequence, there are 2 key frames right next to each other where these two lines would've been. Each keyframe specifies a similar, but not identical, camera position; resulting in a slight camera "jerk" at that point in the cutscene.
    Finally, there are at least 3 lines missing entirely (2 for Arokh and 1 for Rynn?), which would've been spoken before Rynn says "Let's get going!".

Ruined Village:
  • Observation: the sword Rynn uses in the intro cutscene is not Atimar's blade; clearly it also does much more damage.
    Presumably, it was taken by the wartoks after she was knocked out.
    But as for why they didn't finish her off right there and then (or just take her as a slave instead), it's anyone's guess... of course, the obvious reason is "because it wouldn't be much of a game if that were to happen", but that's not the kind of answer I'm looking for.
  • Typo: Arokh's name is misspelled "Arohk" on the map. But let's cut Rynn some slack on that one, given the dire circumstances...
  • Observation: entering the inn's basement from the cave, without having entered it from the ground floor first, causes Rynn to never say her "I never knew this cellar existed!" line.
    Also, the wartok trapped in the room with the spiders was already dead when I found him by approaching from that direction, which is not what's normally supposed to happen.
  • Observation: flying around in debug mode gives a good feel of just how big the level is for Rynn... and how small it would have been for Arokh! And now you can also take Arokh for a spin there, as well! Just mind the resulting bugs!
  • Secret area / easter egg: a wooden outhouse in a small side area near the level transition to Wartok Canyons.
    Oddly, it's located in a place which is quite tricky (but certainly not impossible) to reach without cheating.
    Approaching it causes the door to open, and a wartok emerges - or at least is supposed to, but tends to frequently get stuck on the geometry instead. He's carrying 2 health elixirs, and an invisibility potion.
    Perhaps he was intending to use the invisibility potion for some sort of a silly toilet prank on one of his friends? :D
  • Game-breaking bug (forcing the game into an inconsistent state): the level transition to Wartok Canyons is always active, and it can be crossed by Rynn without Arokh (although that part of the level cannot be reached without Arokh, barring cheating or glitching).
    Needless to say, Bad Things happen if Rynn does that - because she's now hopelessly stuck in Wartok Canyons without Arokh! :(
  • Observation: the area with the winding path and several trees, just past the bridge to Atimar's house, is where the intro cutscene takes place; it's where Rynn and Delon were ambushed by a group of wartoks.
    This raises an interesting question: Rynn and Delon were ambushed on the path from the temple, which is also clearly its sole "normal" exit; yet later on we find Atimar near-dead in the village, which lies further down the same path.
    So, were they in the temple alone, then? Cleaning duty, perhaps?
    I don't think that Atimar (nor the other temple-goers, for that matter) would have simply walked straight past Rynn, who was knocked out cold in the middle of the path, without helping her...
  • Sequence break (minor; small timesave): Rynn's diagonal jump is sufficiently long to easily clear the gap to the central pedestal with Heron's sarcophagus, without raising the intervening platform first. Picking up the crystal in these circumstances causes the (still not raised) platform to instantly teleport to the topmost position, and the stairs then lower normally.
  • Major OSHA violation: the elevator out of Heron's tomb. Lack of basic safety features aside; the ceiling at the upper landing slopes in such a way, that standing on the far left corner of the elevator platform would cause the passenger to get squashed against the very low ceiling there.
    Luckily for Rynn, the ceiling is very slippery, and causes her to get harmlessly pushed outward in that case.
  • Sequence break (major; large timesave): with 2 fiendishly difficult jumps, and a very harrowing swimming sequence (against a strong current, an instakill waterfall, as well as a high risk of drowning), it's possible to bypass Heron's tomb in its entirety :!:, as well as all the events leading up to it!
    Rynn can then climb out of the water quite some ways upstream from Atimar's house, just before the first broken rope bridge.
    This skip could be useful for a glitchless RTA route. The timesave is quite substantial, and the high difficulty is largely offset by its very early occurence in the run.
  • Sequence break (minor; small timesave): with 2 relatively easy diagonal jumps, it's possible to skip from the exit out of Heron's tomb straight to the other side of the toppleable tree/bridge, saving several seconds by not having to go the long way around.
  • Sequence break (minor; small timesave): there's one broken bridge where the gap is a little too wide to jump; it is normally intended that the player goes the other way instead.
    However, Rynn can cross it with either a diagonal jump, or by simply walking on the suspension ropes. This makes for a minor shortcut to the entrance to Arokh's lair.
  • Unusual level design (superfluous item floating in the sky): a visible (not hidden) copy of Heron's soul crystal, which can be picked up while falling :!: (albeit with great difficulty), floats high above the pedestal in Arokh's lair, roughly at the same height as the circular opening in the ceiling; it's clearly visible when approaching the exit from above. Why is it even there? :?
    Interestingly, it's also visible just fine from below - which is to say, when approaching from the normal direction; although it can be quite hard to see against the background of stars in the sky, if you don't know what it is that you're looking at.
    However, for whatever reason, it isn't visible any more during the bonding cutscene - and I've checked that very thoroughly in my recording, with frame advance.
  • Sequence break (minor; little/no timesave): with one very difficult jump, as well as many easier ones, it's possible to reach the exit out of Arokh's lair from above :!:, by starting from the patch of shore to the left of the usual entrance.
    Of course the fall would normally be lethal, but Rynn can nonetheless survive it by using the mysterious grab-at-a-great-distance properties of the floating duplicate Heron's soul crystal to cancel most of her falling velocity, turning the absolutely fatal drop into merely a maiming one (very difficult due to sheer randomness; it took a few tens of tries...). Approaching the pedestal starts the bonding cutscene, as usual.
    It is also possible - although only with considerable difficulty, and no small amount of luck - to survive by dropping from the rim of the exit opening onto the platform where Arokh is standing.
    This requires using some sick midair turns, and performing the skullsplitter move to reduce the falling damage; but even then, starting from full health, Rynn will just barely survive the fall with <10% HP remaining.
    Unfortunately, this sequence break takes roughly as long to perform - if not longer - as simply going in through the normal entrance, so I'd say it's not a viable timesave; it's only interesting because of how ludicrous it is.

Re: Sequence breaks, glitches, secrets, ghosts of content cut, and other observations...

Posted: Wed Apr 25, 2018 6:12 am
by UCyborg
Note: I seem to be unable to replicate the "sword block flying glitch"
It's possible that the patch fixed it. Can't confirm though because I have no idea how to perform it in the first place.

BTW, here's an interesting physics glitch. Try dropping something from the inventory on any artificial bridge. Most objects except the smallest will start moving to one side of the bridge.

Re: Sequence breaks, glitches, secrets, ghosts of content cut, and other observations...

Posted: Wed Apr 25, 2018 2:51 pm
by Mechanist

Here's a video of the "sword flying glitch" in action, starting at about 0:30; for example, most of Ruined Village gets skipped using it.
The effect is similar to, but distinct from, the Tomb Raider "airwalk" glitch (Anniversary/Legend, IIRC?).
I have since managed to replicate it; updated the OP with the new findings.

In the meantime, I have found another strange physics glitch, when dropping Atimar's Blade in the center of Arokh's lair, while standing on the very edge of the high ledge where you enter from the collapsing floor room.
Trying to drop it so that it falls onto the floor far below, sometimes caused it to bug out and fall in very slow motion!
I have it on video, but unfortunately not from the moment when I drop it from the inventory screen.
Managed to replicate this effect at least twice, but it seems very random.

Re: Sequence breaks, glitches, secrets, ghosts of content cut, and other observations...

Posted: Wed Apr 25, 2018 10:20 pm
by UCyborg
I remember that slow motion item falling glitch throughout the game. A bit random occurrence I think.

Re: Sequence breaks, glitches, secrets, ghosts of content cut, and other observations...

Posted: Sun Apr 29, 2018 12:07 pm
by Mechanist
Wow, I'm still not entirely done with Ruined Village yet. I've found a few new glitches, as well as more evidence of cut content; I've updated the OP accordingly.

Here's a list of what had been updated, for reference:
  • Arokh's partially-unused "run into wall" animation,
  • Glitches fixed in the recent releases of the AiO patch,
  • Lines cut from the bonding cutscene,
  • "Arokh's indifference" glitch,
  • "Rynn's stiff back" glitch,
  • Strange left/right movement asymmetry,
  • Added a possible reason for why Arokh's statue has no collision properties whatsoever,
  • Added another way of surviving the fatal drop from the exit of Arokh's lair,
  • "Things to do in Arokh's lair when Rynn is dead".

BTW, here's an interesting physics glitch. Try dropping something from the inventory on any artificial bridge. Most objects except the smallest will start moving to one side of the bridge.
Strange, I was unable to replicate this.
Tried on a few of the bridges in Ruined Village, including the intact stone bridge near the graveyard.

The dropped items (weapons) generally exhibited the expected behavior, sliding downhill - although oddly, the sliding speed wasn't dependent on how steep the slope was.
The only signficant quirk which I noticed was on the rope bridges - when the item reached the center of the bridge, it tended to sink into the planks and become unreachable somehow?

Re: Sequence breaks, glitches, secrets, ghosts of content cut, and other observations...

Posted: Wed May 02, 2018 1:24 am
by UCyborg
The dropped items (weapons) generally exhibited the expected behavior, sliding downhill - although oddly, the sliding speed wasn't dependent on how steep the slope was.

That's what I meant I think, might've used the wrong wording. But yeah, swords in real life wouldn't move with a very small steep like they do in Drakan. Armors are more interesting to watch, they keep the upwards pose until they reach the stopping point.

Re: Sequence breaks, glitches, secrets, ghosts of content cut, and other observations...

Posted: Mon May 21, 2018 7:48 pm
by UCyborg
Another odd glitch, dropping certain items at certain places makes them disappear after you save the game. It definitely works for armors, try the cheat "gimme chain mail" on the starting spot in Ruined Village. Check the comments on AiO Patch's ModDB page.

Edit: model of the item is the factor.