Page 1 of 1

skin texture missing in game

Posted: Wed Apr 23, 2014 5:22 pm
by cieply
recently I experience the little problem with amazon skins - in game there is no texture for skins other than basic
the proble is more enigmatic because the corresponding .mmp file are present and in right place and on top of that earlier it worked - I didn't change anything but when recently started to play with Gladiator (same with skin switcher and other mods that allow to change skin) noticed that skins appeared to have no textures
obviously I checked console but it doesn't say anything about any missing files so I have no idea where to hook to pull this investigation

Re: skin texture missing in game

Posted: Fri Apr 25, 2014 9:47 pm
by prospero
Not sure, but maybe if you deleted the Pak folders...... :roll:

re: deleted pak folders

Posted: Wed Apr 30, 2014 6:41 pm
by cieply
if the pak diectories were a problem it would happen in certain maps I guess but it happens in every single map I use and I have another "instance" of game (where I use and test texture mods, like phelios or MBK's textures) and it works there, no problem

I checked pak folders and they are where they meant to be, even if they shoud be recompiled by game anyway

the worst thing here is tha game uses first texture it can found if there is not properly defined one without giving any warning/debug information

Re: skin texture missing in game

Posted: Thu May 01, 2014 2:04 am
by prospero
The pak folders are compiled only once when you first play the map. They contain info on map structure and textures and allow quicker loading. But they are only created on the first load of any map, so if you alter any textures or alter the map you have to force a rebuild.

There are certain weird happenings that can occur though. Sometimes textures don't seem to load properly. Particle bitmaps seem a bit prone to this. Never figured out why.

it's not pak/ directories fault

Posted: Sat May 03, 2014 3:14 pm
by cieply
I checked that and didn't work
I removed $BOD/Maps/gladiator/pak/* $BOD/Maps/tower/pak/* and started new gladiator game, result: the same
same with $BOD/Maps/Ruins_M4/pak/* and new game

so it's not a reason

i'm running out of new ideas how to solve it

dissapearing textures - act 2

Posted: Wed May 28, 2014 4:30 pm
by cieply
this time in OpenGL raster
it's annoying

1: orc's icon - it's quite often
2: great orc's skin - this shown up recently

both are mystery and ave to be solved!