Modding Mystery

Talk about Severance Blade of Darkness modifications and maps here. No tips or tech support questions please, use the forum above. Note that the game is rated 18 so some content may be unsuitable for younger readers.

Moderators: Ade, prospero

User avatar
prospero
Ancient Dragon
Posts: 1728
Joined: Wed Nov 21, 2001 1:42 am
Location: United Kingdom

Modding Mystery

Postby prospero » Wed Jun 08, 2016 1:14 am

Last week I thought I would play a bit of BOD. :D

Haven't played properly in ages. :roll:

I started up the Ascension mod and quite enjoyed it as it's so long since I played it I had forgotten what was supposed to happen.

I did spot a bug or two here and there and thought I would have a go at fixing them and do a bit of general housekeeping at the same time.
It ten years since I originally made the mod. :shock:

Anyway, I added a few little tweaks. On the whole it all works surprisingly well. Checked the save game. Worked OK.

Then, for some unknown reason the game wouldn't save. Game crashes halfway though saving. :evil:
As well as this I now have a 'crash spot'. Crashes in the same place every time even though I made no changes to the particular area. I've been in and out of the same spot hundreds of times. Never crashed before. Came on all of a sudden.
The weird thing is that I made a test map where I re-created the same area - using the same .bw file. Not a copy but referenced to the original .bw file. Put in all the things that exist in the original mod. That works fine - no crash.

I can't help but think this is damn peculiar. :lol:

I'm pretty sure this is a graphics issue and not code. The same crash happens when I fly down the corridor with the free camera. As soon as a little spot becomes visible - it crashes. I've had this before when you get bad sectors, but it isn't that or it would crash in the test map.

I'm stumped on this one. :?

This is more of a rant than a cry for help. But if anyone has any ideas please shout up. 8)


Another thing. Not so drastic. Every time I start the game in full screen the video options default to a setting that is too bright. I have to reset it every time. (I'm using the OGL raster). It never used to do this.

User avatar
Haraldzz
Dragon
Posts: 72
Joined: Mon Nov 07, 2011 10:29 pm
Location: Latvia
Contact:

Re: Modding Mystery

Postby Haraldzz » Wed Jun 08, 2016 12:32 pm

Heh, one does not simply uninstall BoD. :lol:

Have you tried toying around with the render settings? Last time I played Ascension (admittedly, a few years ago) I actually had no problems whatsoever.

Also, when Fugitive IV?

User avatar
prospero
Ancient Dragon
Posts: 1728
Joined: Wed Nov 21, 2001 1:42 am
Location: United Kingdom

Re: Modding Mystery

Postby prospero » Wed Jun 08, 2016 1:00 pm

Yes I've played around with everything. :lol:

This morning I have managed find the original .MP file which was on a CD among a big stack of backups.

So I've rebuilt the offending room and now it seems to be OK.

Just need to get the save to work. :|



I'm going though all my mods to see if they can be 'improved'. I've got quite a few that are started but not finished
but they tend to be very complicated and therefore time consuming.
FIV pt1 is 99% done but a few bugs to track down.

User avatar
MBK_MBK
Dragon
Posts: 396
Joined: Sun Jun 19, 2011 9:06 am
Location: Spain
Contact:

Re: Modding Mystery

Postby MBK_MBK » Fri Jun 10, 2016 12:16 am

Hello friends :)

This is good news , Master Prospero.
I'm glad to read :D

It seems that is happen similar things to us ... in my old computer also fails my graphics card , in some places of the maps.
Sometimes the error is corrected when the graphics card is set well, but I'm not sure, it depends on the computer .

It's the same with my hyperborean Mod ... the v1.52 is almost completed, but every mistake I correct , comes another problem that crash the game.
So from a small problem, save - load the game , they have emerged 30 more :roll: ... Due to that, I am working in the V1.6, and I have added some more cool things, trying to fix better the code. 8)

Well, I know this is not the topic, but I would like to say:
I have also adapted other great mods, to the configuration of "Hyperborean Mod V1.6" . For example , "Gladiator ", or "Dwarf quest" ... These two mods seems to work well with the configuration of H mod V1.6.
I would like to make work "Fugitive Saga" with my "Hyperborean Mod", but it is very complex and the game crashs... well, may be I get it some day, I will still trying.

Greetings and thanks :)

(Sorry for my bad english, I use google translator.)
Loose your ghosts, because they chain suspiciously your freedom.
My Youtube channel, tests with Hyperborean Mod:
https://www.youtube.com/user/MBEASTKING1980
Web site of Hyperborean mod:
https://sites.google.com/view/bodhyperboreanmodbymbk

User avatar
prospero
Ancient Dragon
Posts: 1728
Joined: Wed Nov 21, 2001 1:42 am
Location: United Kingdom

Re: Modding Mystery

Postby prospero » Fri Jun 10, 2016 3:22 am

Well I have fixed the save. I think..... It was all down to a particle system linked to one of the 'spooks' in level 20.
Why it decided to do it when it's been working fine for the past 10 years is anyones guess. Same thing with the crash spot
which was in the purple room with the Vamp. Took out the flame over the well and all is.... well. :lol:

Playing though further I keep getting other strange and annoying bugs. At the moment I sometimes are unable to lock on
during and after playing the Golem level.

You fix one thing and another bug rears it's head. Apart from that it works quite well.

User avatar
prospero
Ancient Dragon
Posts: 1728
Joined: Wed Nov 21, 2001 1:42 am
Location: United Kingdom

Re: Modding Mystery

Postby prospero » Wed Jun 15, 2016 3:52 am

Latest......

I can save fine up to level 18. If I try saving after the Golems the game crashes.

It also crashes when I try to exit the game. Dunno what that's all about. :? :roll:

User avatar
prospero
Ancient Dragon
Posts: 1728
Joined: Wed Nov 21, 2001 1:42 am
Location: United Kingdom

Re: Modding Mystery

Postby prospero » Wed Jun 15, 2016 12:54 pm

I'm beginning to think the crashes are more to do with my PC than with the actual game code.

I haven't another machine that I can run the game on so I'll upload the new version. Be grateful
if a few folks could have a run though and see how it behaves. :D

User avatar
Haraldzz
Dragon
Posts: 72
Joined: Mon Nov 07, 2011 10:29 pm
Location: Latvia
Contact:

Re: Modding Mystery

Postby Haraldzz » Fri Jun 17, 2016 11:01 am

I haven't another machine that I can run the game on so I'll upload the new version. Be grateful
if a few folks could have a run though and see how it behaves. :D
Sure thing! Been replaying Fugitive out of boredom lately, I wouldn't mind a bit more of BoD.


Return to “Severance BoD: Modding Community”

Who is online

Users browsing this forum: No registered users and 1 guest

cron